Szyfrowane połączenie do forum (https)

Informacje o zmianach i nowych możliwościach Forum

Moderator: gsmok

CHOPIN66
625...1249 postów
625...1249 postów
Posty: 654
Rejestracja: pn, 10 sierpnia 2009, 17:47
Lokalizacja: Gdańsk

Re: Szyfrowane połączenie do forum (https)

Post autor: CHOPIN66 »

Sprzedam radio Loewe Opta Bella 67
Sprzedam własny album MIEXES na oxl
Szczegóły na PW

Boguś
2500...3124 posty
2500...3124 posty
Posty: 2751
Rejestracja: sob, 17 stycznia 2004, 22:10
Lokalizacja: Zawiercie
Kontakt:

Re: Szyfrowane połączenie do forum (https)

Post autor: Boguś »

Aha a tego to nie wiedzialem :(

Awatar użytkownika
Romekd
moderator
Posty: 4828
Rejestracja: pt, 11 kwietnia 2003, 23:47
Lokalizacja: Zawiercie

Re: Szyfrowane połączenie do forum (https)

Post autor: Romekd »

Czołem.
CHOPIN66 pisze:
ndz, 5 stycznia 2020, 20:46
Bo są dwie wersje triody , z http i https
https://www.forum-trioda.pl/index.php
http://www.forum-trioda.pl/index.php
:D
Jednak nie wszystko działa poprawnie. Gdy jestem na drugiej stronie tego wątku, przed adresem w przeglądarce wyświetla mi się kłódka, która informuje o bezpiecznym połączeniu. Gdy jednak powrócę na pierwszą stronę wątku, kłódka znika, a wg informacji wyświetlanej przez przeglądarkę (wyświetlanej po najechaniu kursorem na literkę "i" w kółeczku przed adresem i kliknięciu na niej /lub po kliknięciu w kłódkę z wykrzyknikiem w przeglądarce Mozilla Firefox/), połączenie przestaje być bezpieczne... :( Czy ktoś z Kolegów może sprawdzić, czy u niego jest podobnie?

Pozdrawiam
Romek
α β Σ Φ Ω μ π °C ± √ ² < ≤ ≥ > ^

Boguś
2500...3124 posty
2500...3124 posty
Posty: 2751
Rejestracja: sob, 17 stycznia 2004, 22:10
Lokalizacja: Zawiercie
Kontakt:

Re: Szyfrowane połączenie do forum (https)

Post autor: Boguś »

Romku, no wlasnie o tym napislem. Jest wlasnie dokladnie tak jak piszesz

Awatar użytkownika
Romekd
moderator
Posty: 4828
Rejestracja: pt, 11 kwietnia 2003, 23:47
Lokalizacja: Zawiercie

Re: Szyfrowane połączenie do forum (https)

Post autor: Romekd »

Dziękuję Boguś. Wynika z tego, że adres rozpoczynający się od "https...", również nie zawsze jest bezpieczny, o czym wspominali już Koledzy kaem i Thereminator... :(

Pozdrawiam
Romek
α β Σ Φ Ω μ π °C ± √ ² < ≤ ≥ > ^

Awatar użytkownika
Thereminator
3125...6249 postów
3125...6249 postów
Posty: 6023
Rejestracja: sob, 2 kwietnia 2005, 21:42
Lokalizacja: Nizina Wschodnioeuropejska
Kontakt:

Re: Szyfrowane połączenie do forum (https)

Post autor: Thereminator »

U mnie wczoraj i dziś (przynajmniej na razie) https działa jak należy.
W teorii nie ma różnicy między praktyką a teorią. W praktyce jest.

Boguś
2500...3124 posty
2500...3124 posty
Posty: 2751
Rejestracja: sob, 17 stycznia 2004, 22:10
Lokalizacja: Zawiercie
Kontakt:

Re: Szyfrowane połączenie do forum (https)

Post autor: Boguś »

Thereminator pisze:
pn, 6 stycznia 2020, 10:42
U mnie wczoraj i dziś (przynajmniej na razie) https działa jak należy.
Po przeczytaniu tego postu cofnij sie na 1 srone tego postu. Bo u mnie od razu kradną kłódkę ;)

Awatar użytkownika
Thereminator
3125...6249 postów
3125...6249 postów
Posty: 6023
Rejestracja: sob, 2 kwietnia 2005, 21:42
Lokalizacja: Nizina Wschodnioeuropejska
Kontakt:

Re: Szyfrowane połączenie do forum (https)

Post autor: Thereminator »

U mnie nie.
W teorii nie ma różnicy między praktyką a teorią. W praktyce jest.

Awatar użytkownika
disaster
625...1249 postów
625...1249 postów
Posty: 1154
Rejestracja: wt, 5 października 2010, 21:13
Lokalizacja: Brzeziny k.Łodzi

Re: Szyfrowane połączenie do forum (https)

Post autor: disaster »

Bo do katalogu głównego strony trzeba wrzucić plik .htaccess z taką zawartością:

Kod: Zaznacz cały

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IfModule>
albo podobną w zależności od tego na czym ten serwer siedzi.
Z przyczyn technicznych koniec świata odwołany.
Poszukuję viewtopic.php?p=304055#p304055

k4be
500...624 posty
500...624 posty
Posty: 504
Rejestracja: pn, 6 lutego 2006, 22:20
Lokalizacja: Świdnica
Kontakt:

Re: Szyfrowane połączenie do forum (https)

Post autor: k4be »

Pierwsza strona nie jest wykazywana jako "bezpieczna", bo znajdujący się na niej, wrzucony przez kaem obrazek nie korzysta z HTTPS.

ODPOWIEDZ